Question: Local Galaxy : tbl2asn_23_7 installation fails (python error)
0
gravatar for mokona__modoki
2.4 years ago by
France
mokona__modoki10 wrote:

Hi all,

I hope someone can help me deal with  my problem : I am currently customizing a local version of the Galaxy platform on my computer and I'd like to install Prokka (maintained by CRS4) everything works pretty well until Galaxy tries to install the tbl2asn_23_7 package, a dependency owned by takadonet. I have the following error and i must say I've tried quite a lot of things to solve the issue but it did not work:



File "/home/galaxy/galaxy-dist/lib/tool_shed/galaxy_install/install_manager.py", line 110, in install_and_build_package_via_fabric

tool_dependency = self.install_and_build_package( app, tool_shed_repository, tool_dependency, actions_dict )
File "/home/galaxy/galaxy-dist/lib/tool_shed/galaxy_install/install_manager.py", line 79, in install_and_build_package
current_dir = os.path.abspath( os.path.join( work_dir, dir ) )
File "/usr/lib/python2.7/posixpath.py", line 66, in join
if b.startswith('/'):

'NoneType' object has no attribute 'startswith'

It looks like a python error but there is probably another problem somewhere.

Any ideas ?

Thanks a lot




 

ADD COMMENTlink modified 2.4 years ago by arnold.knijn0 • written 2.4 years ago by mokona__modoki10
1
gravatar for Dannon Baker
2.4 years ago by
Dannon Baker3.6k
United States
Dannon Baker3.6k wrote:

I've asked takadonet about this and, while I don't (yet) know what the actual issue is, he says that reinstalling the package from the admin menu will resolve the issue.  Can you give this a try and let me know if it works for you?

Edit:  This should also be fixed in newer releases of galaxy, I think we figured out which issue you were running into.

ADD COMMENTlink modified 2.4 years ago • written 2.4 years ago by Dannon Baker3.6k
0
gravatar for arnold.knijn
2.4 years ago by
Italy
arnold.knijn0 wrote:

I can confirm that the latest version of Galaxy solves the problem. Version 2014.06.02 had the same error described above, while Galaxy version 2014.10.06 installed the tbl2asn_23_7 package successfully.

ADD COMMENTlink written 2.4 years ago by arnold.knijn0
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 78 users visited in the last hour