Question: History Not Updating For Multiple Instances Of Galaxy
0
gravatar for Neil.Burdett@csiro.au
5.5 years ago by
Neil.Burdett@csiro.au310 wrote:
Hi, I have three instances of galaxy running on the same Linux box. My "/etc/apache2/sites-available/default" is: RewriteEngine on RewriteRule ^/galaxy-csiro$ /galaxy-csiro/ [R] RewriteRule ^/galaxy-csiro/static/style/(.*) /home/galaxy /galaxy-csiro/static/june_2007_style/blue/$1 [L] RewriteRule ^/galaxy-csiro/static/scripts/(.*) /home/galaxy /galaxy-csiro/static/scripts/packed/$1 [L] RewriteRule ^/galaxy-csiro/static/(.*) /home/galaxy/galaxy- csiro/static/$1 [L] RewriteRule ^/galaxy-csiro/favicon.ico /home/galaxy/galaxy- csiro/static/favicon.ico [L] RewriteRule ^/galaxy-csiro/robots.txt /home/galaxy/galaxy- csiro/static/robots.txt [L] RewriteRule ^/galaxy-csiro(.*) http://localhost:9080$1 [P] RewriteRule ^/galaxy-cte$ /galaxy-cte/ [R] RewriteRule ^/galaxy-cte/static/style/(.*) /home/galaxy /galaxy-cte/static/june_2007_style/blue/$1 [L] RewriteRule ^/galaxy-cte/static/scripts/(.*) /home/galaxy /galaxy-cte/static/scripts/packed/$1 [L] RewriteRule ^/galaxy-cte/static/(.*) /home/galaxy/galaxy- cte/static/$1 [L] RewriteRule ^/galaxy-cte/favicon.ico /home/galaxy/galaxy- cte/static/favicon.ico [L] RewriteRule ^/galaxy-cte/robots.txt /home/galaxy/galaxy- cte/static/robots.txt [L] RewriteRule ^/galaxy-cte(.*) http://localhost:9000$1 [P] RewriteRule ^/galaxy-Newcastle$ /galaxy-Newcastle/ [R] RewriteRule ^/galaxy-Newcastle/static/style/(.*) /home/galaxy /galaxy-Newcastle/static/june_2007_style/blue/$1 [L] RewriteRule ^/galaxy-Newcastle/static/scripts/(.*) /home/galaxy/galaxy-Newcastle/static/scripts/packed/$1 [L] RewriteRule ^/galaxy-Newcastle/static/(.*) /home/galaxy /galaxy-Newcastle/static/$1 [L] RewriteRule ^/galaxy-Newcastle/favicon.ico /home/galaxy /galaxy-Newcastle/static/favicon.ico [L] RewriteRule ^/galaxy-Newcastle/robots.txt /home/galaxy/galaxy- Newcastle/static/robots.txt [L] RewriteRule ^/galaxy-Newcastle(.*) http://localhost:9010$1 [P] I can view all the instances However, when I try and "Get Data" and upload a file the history side panel remains empty. I can see that the files have been uploaded to (for example) % ls -lrt galaxy-Newcastle/database/files/000/ total 22868 -rw-rw-r-- 1 galaxy galaxy 23017819 Feb 21 13:01 dataset_1.dat -rw-rw-r-- 1 galaxy galaxy 187339 Feb 21 13:02 dataset_2.dat -rw-rw-r-- 1 galaxy galaxy 206568 Feb 21 13:03 dataset_3.dat Any ideas much appreciated... The log file state: Debug at: http://barium-rbh/galaxy-Newcastle/_debug/view/1361342321 127.0.0.1 - - [21/Feb/2013:13:16:21 +1000] "GET /galaxy- Newcastle/tool_runner?tool_id=upload1 HTTP/1.1" 200 - "http://barium- rbh/galaxy-Newcastle/root/tool_menu" "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:18.0) Gecko/20100101 Firefox/18.0" galaxy.web.framework DEBUG 2013-02-21 13:16:28,630 Error: this request returned None from get_history(): http://barium-rbh/galaxy- Newcastle/tool_runner/upload_async_create galaxy.web.framework DEBUG 2013-02-21 13:16:28,630 Error: this request returned None from get_history(): http://barium-rbh/galaxy- Newcastle/tool_runner/upload_async_create galaxy.web.framework DEBUG 2013-02-21 13:16:28,631 Error: this request returned None from get_history(): http://barium-rbh/galaxy- Newcastle/tool_runner/upload_async_create galaxy.web.framework DEBUG 2013-02-21 13:16:28,631 Error: this request returned None from get_history(): http://barium-rbh/galaxy- Newcastle/tool_runner/upload_async_create galaxy.web.framework DEBUG 2013-02-21 13:16:28,631 Error: this request returned None from get_history(): http://barium-rbh/galaxy- Newcastle/tool_runner/upload_async_create galaxy.web.framework DEBUG 2013-02-21 13:16:28,631 Error: this request returned None from get_history(): http://barium-rbh/galaxy- Newcastle/tool_runner/upload_async_create galaxy.web.framework DEBUG 2013-02-21 13:16:28,631 Error: this request returned None from get_history(): http://barium-rbh/galaxy- Newcastle/tool_runner/upload_async_create 127.0.0.1 - - [21/Feb/2013:13:16:28 +1000] "POST /galaxy- Newcastle/tool_runner/upload_async_create HTTP/1.1" 500 - "http ://barium-rbh/galaxy-Newcastle/" "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:18.0) Gecko/20100101 Firefox/18.0" Debug at: http://barium-rbh/galaxy-Newcastle/_debug/view/1361342322 127.0.0.1 - - [21/Feb/2013:13:16:28 +1000] "GET /galaxy- Newcastle/tool_runner/upload_async_message HTTP/1.1" 200 - "http ://barium-rbh/galaxy-Newcastle/" "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:18.0) Gecko/20100101 Firefox/18.0" 127.0.0.1 - - [21/Feb/2013:13:16:28 +1000] "GET /galaxy- Newcastle/history HTTP/1.1" 200 - "http://barium-rbh/galaxy- Newcastle/tool_runner/upload_async_message" "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:18.0) Gecko/20100101 Firefox/18.0" galaxy.web.framework DEBUG 2013-02-21 13:16:29,261 Error: this request returned None from get_history(): http://barium-rbh/galaxy- Newcastle/root/user_get_usage 127.0.0.1 - - [21/Feb/2013:13:16:29 +1000] "POST /galaxy- Newcastle/root/user_get_usage HTTP/1.1" 500 - "http://barium-rbh /galaxy-Newcastle/history" "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:18.0) Gecko/20100101 Firefox/18.0" Debug at: http://barium-rbh/galaxy-Newcastle/_debug/view/1361342323 galaxy.tools.actions.upload_common INFO 2013-02-21 13:16:30,841 tool upload1 created job id 4 127.0.0.1 - - [21/Feb/2013:13:16:28 +1000] "POST /galaxy- Newcastle/tool_runner/index HTTP/1.1" 200 - "http://barium-rbh/galaxy- Newcastle/tool_runner?tool_id=upload1" "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:18.0) Gecko/20100101 Firefox/18.0" 127.0.0.1 - - [21/Feb/2013:13:16:30 +1000] "GET /galaxy- Newcastle/history HTTP/1.1" 200 - "http://barium-rbh/galaxy- Newcastle/tool_runner/index" "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:18.0) Gecko/20100101 Firefox/18.0" galaxy.web.framework DEBUG 2013-02-21 13:16:31,347 Error: this request returned None from get_history(): http://barium-rbh/galaxy- Newcastle/root/user_get_usage 127.0.0.1 - - [21/Feb/2013:13:16:31 +1000] "POST /galaxy- Newcastle/root/user_get_usage HTTP/1.1" 500 - "http://barium-rbh /galaxy-Newcastle/history" "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:18.0) Gecko/20100101 Firefox/18.0" Debug at: http://barium-rbh/galaxy-Newcastle/_debug/view/1361342324 galaxy.jobs.manager DEBUG 2013-02-21 13:16:33,263 (4) Job assigned to handler 'main' galaxy.jobs DEBUG 2013-02-21 13:16:38,574 (4) Working directory for job is: /home/galaxy/galaxy- Newcastle/database/job_working_directory/000/4 galaxy.jobs.handler DEBUG 2013-02-21 13:16:38,574 dispatching job 4 to local runner galaxy.jobs.handler INFO 2013-02-21 13:16:38,837 (4) Job dispatched galaxy.jobs.runners.local DEBUG 2013-02-21 13:16:39,130 executing: python /home/galaxy/galaxy-Newcastle/tools/data_source/upload.py /home/galaxy/galaxy-Newcastle /home/galaxy/galaxy- Newcastle/database/tmp/tmpQK6VjP /home/galaxy/galaxy- Newcastle/database/tmp/tmpD_ySP1 4:/home/galaxy/galaxy-Newcast le/database/job_working_directory/000/4/dataset_4_files:/home/galaxy /galaxy-Newcastle/database/files/000/dataset_4.dat galaxy.jobs.runners.local DEBUG 2013-02-21 13:16:39,549 execution finished: python /home/galaxy/galaxy- Newcastle/tools/data_source/upload.py /home/galaxy/galaxy-Newcastle /home/galaxy/galaxy-Newcastle/database/tmp/tmpQK6VjP /home/galaxy /galaxy-Newcastle/database/tmp/tmpD_ySP1 4:/home/galaxy /galaxy-Newcastle/database/job_working_directory/000/4/dataset_4_files :/home/galaxy/galaxy-Newcastle/database/files/000/dataset_4.dat galaxy.jobs DEBUG 2013-02-21 13:16:39,590 The tool did not define exit code or stdio handling; checking stderr for success galaxy.jobs DEBUG 2013-02-21 13:16:39,900 job 4 ended So some reason the history isn't getting updated for multiple instances of Galaxy Thanks Neil
galaxy • 992 views
ADD COMMENTlink modified 5.5 years ago • written 5.5 years ago by Neil.Burdett@csiro.au310
0
gravatar for Neil.Burdett@csiro.au
5.5 years ago by
Neil.Burdett@csiro.au310 wrote:
Further, when I try "register" I add an email address and password, but the system still doesn't log me in Maybe this is a database configuration issue? I didn't think I'd need to state any specific entries in universe as I am using physically separate directories i.e. /home/galaxy/galaxy-cte/ .... i.e. /home/galaxy/galaxy-Newcastle/ .... Cheers Neil To: galaxy-dev@lists.bx.psu.edu Cc: galaxy-user@lists.bx.psu.edu Subject: History not updating for multiple instances of Galaxy Hi, I have three instances of galaxy running on the same Linux box. My "/etc/apache2/sites-available/default" is: RewriteEngine on RewriteRule ^/galaxy-csiro$ /galaxy-csiro/ [R] RewriteRule ^/galaxy-csiro/static/style/(.*) /home/galaxy /galaxy-csiro/static/june_2007_style/blue/$1 [L] RewriteRule ^/galaxy-csiro/static/scripts/(.*) /home/galaxy /galaxy-csiro/static/scripts/packed/$1 [L] RewriteRule ^/galaxy-csiro/static/(.*) /home/galaxy/galaxy- csiro/static/$1 [L] RewriteRule ^/galaxy-csiro/favicon.ico /home/galaxy/galaxy- csiro/static/favicon.ico [L] RewriteRule ^/galaxy-csiro/robots.txt /home/galaxy/galaxy- csiro/static/robots.txt [L] RewriteRule ^/galaxy-csiro(.*) http://localhost:9080$1 [P] RewriteRule ^/galaxy-cte$ /galaxy-cte/ [R] RewriteRule ^/galaxy-cte/static/style/(.*) /home/galaxy /galaxy-cte/static/june_2007_style/blue/$1 [L] RewriteRule ^/galaxy-cte/static/scripts/(.*) /home/galaxy /galaxy-cte/static/scripts/packed/$1 [L] RewriteRule ^/galaxy-cte/static/(.*) /home/galaxy/galaxy- cte/static/$1 [L] RewriteRule ^/galaxy-cte/favicon.ico /home/galaxy/galaxy- cte/static/favicon.ico [L] RewriteRule ^/galaxy-cte/robots.txt /home/galaxy/galaxy- cte/static/robots.txt [L] RewriteRule ^/galaxy-cte(.*) http://localhost:9000$1 [P] RewriteRule ^/galaxy-Newcastle$ /galaxy-Newcastle/ [R] RewriteRule ^/galaxy-Newcastle/static/style/(.*) /home/galaxy /galaxy-Newcastle/static/june_2007_style/blue/$1 [L] RewriteRule ^/galaxy-Newcastle/static/scripts/(.*) /home/galaxy/galaxy-Newcastle/static/scripts/packed/$1 [L] RewriteRule ^/galaxy-Newcastle/static/(.*) /home/galaxy /galaxy-Newcastle/static/$1 [L] RewriteRule ^/galaxy-Newcastle/favicon.ico /home/galaxy /galaxy-Newcastle/static/favicon.ico [L] RewriteRule ^/galaxy-Newcastle/robots.txt /home/galaxy/galaxy- Newcastle/static/robots.txt [L] RewriteRule ^/galaxy-Newcastle(.*) http://localhost:9010$1 [P] I can view all the instances However, when I try and "Get Data" and upload a file the history side panel remains empty. I can see that the files have been uploaded to (for example) % ls -lrt galaxy-Newcastle/database/files/000/ total 22868 -rw-rw-r-- 1 galaxy galaxy 23017819 Feb 21 13:01 dataset_1.dat -rw-rw-r-- 1 galaxy galaxy 187339 Feb 21 13:02 dataset_2.dat -rw-rw-r-- 1 galaxy galaxy 206568 Feb 21 13:03 dataset_3.dat Any ideas much appreciated... The log file state: Debug at: http://barium-rbh/galaxy-Newcastle/_debug/view/1361342321 127.0.0.1 - - [21/Feb/2013:13:16:21 +1000] "GET /galaxy- Newcastle/tool_runner?tool_id=upload1 HTTP/1.1" 200 - "http://barium- rbh/galaxy-Newcastle/root/tool_menu" "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:18.0) Gecko/20100101 Firefox/18.0" galaxy.web.framework DEBUG 2013-02-21 13:16:28,630 Error: this request returned None from get_history(): http://barium-rbh/galaxy- Newcastle/tool_runner/upload_async_create galaxy.web.framework DEBUG 2013-02-21 13:16:28,630 Error: this request returned None from get_history(): http://barium-rbh/galaxy- Newcastle/tool_runner/upload_async_create galaxy.web.framework DEBUG 2013-02-21 13:16:28,631 Error: this request returned None from get_history(): http://barium-rbh/galaxy- Newcastle/tool_runner/upload_async_create galaxy.web.framework DEBUG 2013-02-21 13:16:28,631 Error: this request returned None from get_history(): http://barium-rbh/galaxy- Newcastle/tool_runner/upload_async_create galaxy.web.framework DEBUG 2013-02-21 13:16:28,631 Error: this request returned None from get_history(): http://barium-rbh/galaxy- Newcastle/tool_runner/upload_async_create galaxy.web.framework DEBUG 2013-02-21 13:16:28,631 Error: this request returned None from get_history(): http://barium-rbh/galaxy- Newcastle/tool_runner/upload_async_create galaxy.web.framework DEBUG 2013-02-21 13:16:28,631 Error: this request returned None from get_history(): http://barium-rbh/galaxy- Newcastle/tool_runner/upload_async_create 127.0.0.1 - - [21/Feb/2013:13:16:28 +1000] "POST /galaxy- Newcastle/tool_runner/upload_async_create HTTP/1.1" 500 - "http ://barium-rbh/galaxy-Newcastle/" "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:18.0) Gecko/20100101 Firefox/18.0" Debug at: http://barium-rbh/galaxy-Newcastle/_debug/view/1361342322 127.0.0.1 - - [21/Feb/2013:13:16:28 +1000] "GET /galaxy- Newcastle/tool_runner/upload_async_message HTTP/1.1" 200 - "http ://barium-rbh/galaxy-Newcastle/" "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:18.0) Gecko/20100101 Firefox/18.0" 127.0.0.1 - - [21/Feb/2013:13:16:28 +1000] "GET /galaxy- Newcastle/history HTTP/1.1" 200 - "http://barium-rbh/galaxy- Newcastle/tool_runner/upload_async_message" "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:18.0) Gecko/20100101 Firefox/18.0" galaxy.web.framework DEBUG 2013-02-21 13:16:29,261 Error: this request returned None from get_history(): http://barium-rbh/galaxy- Newcastle/root/user_get_usage 127.0.0.1 - - [21/Feb/2013:13:16:29 +1000] "POST /galaxy- Newcastle/root/user_get_usage HTTP/1.1" 500 - "http://barium-rbh /galaxy-Newcastle/history" "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:18.0) Gecko/20100101 Firefox/18.0" Debug at: http://barium-rbh/galaxy-Newcastle/_debug/view/1361342323 galaxy.tools.actions.upload_common INFO 2013-02-21 13:16:30,841 tool upload1 created job id 4 127.0.0.1 - - [21/Feb/2013:13:16:28 +1000] "POST /galaxy- Newcastle/tool_runner/index HTTP/1.1" 200 - "http://barium-rbh/galaxy- Newcastle/tool_runner?tool_id=upload1" "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:18.0) Gecko/20100101 Firefox/18.0" 127.0.0.1 - - [21/Feb/2013:13:16:30 +1000] "GET /galaxy- Newcastle/history HTTP/1.1" 200 - "http://barium-rbh/galaxy- Newcastle/tool_runner/index" "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:18.0) Gecko/20100101 Firefox/18.0" galaxy.web.framework DEBUG 2013-02-21 13:16:31,347 Error: this request returned None from get_history(): http://barium-rbh/galaxy- Newcastle/root/user_get_usage 127.0.0.1 - - [21/Feb/2013:13:16:31 +1000] "POST /galaxy- Newcastle/root/user_get_usage HTTP/1.1" 500 - "http://barium-rbh /galaxy-Newcastle/history" "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:18.0) Gecko/20100101 Firefox/18.0" Debug at: http://barium-rbh/galaxy-Newcastle/_debug/view/1361342324 galaxy.jobs.manager DEBUG 2013-02-21 13:16:33,263 (4) Job assigned to handler 'main' galaxy.jobs DEBUG 2013-02-21 13:16:38,574 (4) Working directory for job is: /home/galaxy/galaxy- Newcastle/database/job_working_directory/000/4 galaxy.jobs.handler DEBUG 2013-02-21 13:16:38,574 dispatching job 4 to local runner galaxy.jobs.handler INFO 2013-02-21 13:16:38,837 (4) Job dispatched galaxy.jobs.runners.local DEBUG 2013-02-21 13:16:39,130 executing: python /home/galaxy/galaxy-Newcastle/tools/data_source/upload.py /home/galaxy/galaxy-Newcastle /home/galaxy/galaxy- Newcastle/database/tmp/tmpQK6VjP /home/galaxy/galaxy- Newcastle/database/tmp/tmpD_ySP1 4:/home/galaxy/galaxy-Newcast le/database/job_working_directory/000/4/dataset_4_files:/home/galaxy /galaxy-Newcastle/database/files/000/dataset_4.dat galaxy.jobs.runners.local DEBUG 2013-02-21 13:16:39,549 execution finished: python /home/galaxy/galaxy- Newcastle/tools/data_source/upload.py /home/galaxy/galaxy-Newcastle /home/galaxy/galaxy-Newcastle/database/tmp/tmpQK6VjP /home/galaxy /galaxy-Newcastle/database/tmp/tmpD_ySP1 4:/home/galaxy /galaxy-Newcastle/database/job_working_directory/000/4/dataset_4_files :/home/galaxy/galaxy-Newcastle/database/files/000/dataset_4.dat galaxy.jobs DEBUG 2013-02-21 13:16:39,590 The tool did not define exit code or stdio handling; checking stderr for success galaxy.jobs DEBUG 2013-02-21 13:16:39,900 job 4 ended So some reason the history isn't getting updated for multiple instances of Galaxy Thanks Neil
ADD COMMENTlink written 5.5 years ago by Neil.Burdett@csiro.au310
The logging in problem sounds like a cookie path issue to me, I had something similar when I added second public Galaxy to our server (in my case, a live on and a dev one). Peter
ADD REPLYlink written 5.5 years ago by Peter Cock1.4k
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 152 users visited in the last hour