Question: Adding customs tools for galaxy docker instance
0
gravatar for mohan.at145
16 days ago by
mohan.at1450 wrote:

I'm trying to add a tool from the test toolshed. since it is not avilable through the galaxy interface, I downloaded it and then tried to add as custom tools to the galaxy docker instance but it doesn't work.

This is the code:

docker run -it --mount type=bind,source="$(pwd)",target=/local_tools --env "GALAXY_CONFIG_TOOL_CONFIG_FILE =config/tool_conf.xml.sample,config/shed_tool_conf.xml.sample,local_tools/my_tools_conf.xml" -p 8080:80 -p 8021:21 -p 8022:22 bgruening/galaxy-stable

working directory : galaxy/tools/local_tools

inside local_tools i have : filtering.py filtering.xml my_tools_conf.xml

This error comes up over and over :

DEBUG:galaxy.app:python path is: lib/, lib/, ., , /galaxy_venv/bin, /galaxy_venv/lib/python2.7, /galaxy_venv/lib/python2.7/plat-x86_64-linux-gnu, /galaxy_venv/lib/python2.7/lib-tk, /galaxy_venv/lib/python2.7/lib-old, /galaxy_venv/lib/python2.7/lib-dynload, /usr/lib/python2.7, /usr/lib/python2.7/plat-x86_64-linux-gnu, /usr/lib/python2.7/lib-tk, /galaxy_venv/local/lib/python2.7/site-packages DEBUG:galaxy.containers:config file './config/containers_conf.yml' does not exist, running with default config Traceback (most recent call last): File "lib/galaxy/webapps/galaxy/buildapp.py", line 49, in app_factory app = galaxy.app.UniverseApplication(global_conf=global_conf, **kwargs) File "lib/galaxy/app.py", line 65, in __init__ self.config.check() File "lib/galaxy/config.py", line 827, in check raise ConfigurationError("Tool config file not found: %s" % path) ConfigurationError: Tool config file not found: ./local_tools/my_tools_conf.xml

can somebody tell me what would be wrong with this procedure?

ADD COMMENTlink modified 7 days ago • written 16 days ago by mohan.at1450

Hello,

I asked for help at the dedicated Gitter channel: https://gitter.im/bgruening/docker-galaxy-stable?at=5bdcb3cbcd2a6b5bdc8761de

They may post back here, or at the chat, and please feel free to join in the conversation there. Something looks to be wrong with the paths in the install command but I'm sure not exactly how to fix it, if there are known issues, etc.

Thanks! Jen, Galaxy team

ADD REPLYlink written 12 days ago by Jennifer Hillman Jackson25k

Cross-posted here: https://github.com/bgruening/docker-galaxy-stable/issues/461

ADD REPLYlink written 12 days ago by Jennifer Hillman Jackson25k
0
gravatar for Bjoern Gruening
12 days ago by
Bjoern Gruening5.1k
Germany
Bjoern Gruening5.1k wrote:

Hi,

You can enable test toolshed installation with -e ENABLE_TTS_INSTALL=True see here for more information: https://github.com/bgruening/docker-galaxy-stable#magic-environment-variables--toc

Otherwise, I think you need to specify an absolute path in your path to the shed_tools file: "GALAXY_CONFIG_TOOL_CONFIG_FILE =config/tool_conf.xml.sample,config/shed_tool_conf.xml.sample,/local_tools/my_tools_conf.xml"

Cheers, Bjoern

ADD COMMENTlink written 12 days ago by Bjoern Gruening5.1k
0
gravatar for mohan.at145
7 days ago by
mohan.at1450 wrote:

Sorry for the late reply. The 1st method works fine. thank you.

ADD COMMENTlink written 7 days ago by mohan.at1450
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 116 users visited in the last hour