Question: Dockerised galaxy and activation emails with incorrect links
1
gravatar for carlos.horro
19 days ago by
carlos.horro10
carlos.horro10 wrote:

Hi,

This is a bit tricky question. I’ve an own Galaxy Docker flavor mainly based on bgruening/galaxy-stable. On the host machine I have another Galaxy instance installed which works fine but it’s getting older and it will be at some point replaced by the Docker container. Everything is working fine in the Dockerised galaxy but the activation emails. I’ve used the same galaxy.ini email params in both the host server and the Docker container:

——

docker run -d -p 7080:80 -p 7021:21 -p 7022:22 -p 7002:9002 \

    -v /mnt/galaxy/storage_galaxy_flavor//:/export/ \

    -e "GALAXY_CONFIG_ADMIN_USERS=carlos.horro@uib.no" \

    -e "GALAXY_CONFIG_MASTER_API_KEY=xxx” \

    -e "GALAXY_CONFIG_BRAND='PROBE-Docker Galaxy'" \

    -e "GALAXY_CONFIG_JOB_CONFIG_FILE=/galaxy-central/config/job_conf.xml" \

    -e "NONUSE=slurmd,slurmctld" \

    -e "GALAXY_CONFIG_USER_ACTIVATION_ON=True" \

    -e "GALAXY_CONFIG_smtp_server=smtp.gmail.com:587" \

    -e "GALAXY_CONFIG_SMTP_USERNAME=server.probe.uib@gmail.com" \

    -e "GALAXY_CONFIG_SMTP_PASSWORD=xxx” \

    -e "GALAXY_CONFIG_SMTP_USE_TLS=yes" \

    -e "GALAXY_CONFIG_ACTIVATION_EMAIL=server.probe.uib@gmail.com" \

    -e "GALAXY_CONFIG_ERROR_EMAIL_TO=server.probe.uib@gmail.com" \

    -e "GALAXY_CONFIG_EMAIL_FROM=server.probe.uib@gmail.com" \

    probe_tools

——

but whilst the first one works fine, the dockerised galaxy send emails with links making reference to localhost instead of the machine’s IP+dockerised port:



———

Hello admin,

In order to complete the activation process for carlos.horro@uib.no begun on 10/24/18 at localhost:7080, please click on the following link to verify your account:

http://localhost:7080/activate?email=carlos.horro%40uib.no&activation_token=3f0f12d9b4f8de25d0c8abe075aa404681288177 
——

I think this is related to the fact that these emails are rejected by the mail servers of the receivers:


——

550 The message was considered as spam. If you disagree, please contact postmaster@uib.no enclosing this tag: 2001:700:200:6::701f:1gFIei-001sMT-MM X-UiB-SpamReport: yes sender_reject server.probe.uib@gmail.com

——

I have a postfix installed into the host server but, if I’m not wrong, it is never supposed to be used in this case as the mail params directly refers to the gmail server.
 Do you know what could I be missing here, please?

Greetings

galaxy email • 48 views
ADD COMMENTlink written 19 days ago by carlos.horro10
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 117 users visited in the last hour