Question: Jobs don't run, workflows don't initiate
0
gravatar for CF
9 weeks ago by
CF • 0
CF • 0 wrote:

Greetings,

I have been using a local galaxy instance successfully for some time. However, suddenly galaxy will no longer run jobs. It will add them to the queue, but they never start running. Additionally, when I try to run workflows, it says they are successfully invoked, but it does not add the jobs to my history. After searching for answers, I updated the galaxy instance to 18.05 following instructions on galaxyproject.org, however this did not solve the issue. I appreciate any advice on this problem.

software error galaxy • 242 views
ADD COMMENT • link • modified 9 weeks ago • written 9 weeks ago by CF • 0
0
gravatar for Martin Čech
9 weeks ago by
Martin Čech ♦♦ 4.9k
United States
Martin Čech ♦♦ 4.9k wrote:

This was a bug on our side, which has been fixed today. All the queued jobs should be finished or at least running by now. Sorry for the inconvenience.

ADD COMMENT • link written 9 weeks ago by Martin Čech ♦♦ 4.9k
0
gravatar for CF
9 weeks ago by
CF • 0
CF • 0 wrote:

Hi Martin,

Unfortunately, I don't think that applies here, as I am using a local galaxy instance. I have narrowed the problem down somewhat though. Originally I had noticed that some of the Picard tools fail with an error suggesting I am running out of memory. So I increased the memory available to java using _JAVA_OPTIONS in the picard_macros.xml file (the default is only 2gb). That was when the jobs and workflows suddenly started failing to run. I have reproduced this on a completely clean install of 18.05. Frustratingly, the problem persists despite even restoring the original picard_macros.xml.

ADD COMMENT • link modified 9 weeks ago • written 9 weeks ago by CF • 0

Ah, I see, sorry for the misunderstanding.

Try modifying the JAVA_OPTIONS in your configuration, not in the tool, as described here: https://docs.galaxyproject.org/en/master/admin/jobs.html?highlight=_java_options#environment-modifications

I am not sure that will change the behavior, but it is definitely the proper way to set this.

ADD REPLY • link written 9 weeks ago by Martin Čech ♦♦ 4.9k

No worries. I tried to set JAVA_OPTIONS using the job_conf.xml file, however this generates the same problem.

ADD REPLY • link written 9 weeks ago by CF • 0
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 176 users visited in the last hour