Question: Barcode splitter error "Can't locate Data/Dumper.pm" - ticketed issue, see answer for details
2
gravatar for e.bakhmet
4 weeks ago by
e.bakhmet30
e.bakhmet30 wrote:

Hello everyone!

Here's some promlem with barcode splitter in usegalaxy. I want to sort my fastq file to several files through there barcodes. I tryed to use fastq, fastqsanger and fasta, but it doesn't work. Barcodes are in text file (I also tryed to use it as a fasta file) with identifier and barcodes separated by TAB as in barcode splitter description.

Here is an error: "Dataset Error An error occured while running the tool toolshed.g2.bx.psu.edu/repos/devteam/fastx_barcode_splitter/cshl_fastx_barcode_splitter/1.0.0

Tool execution generated the following messages:

Can't locate Data/Dumper.pm in @INC (@INC contains: /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at /galaxy/main/deps/fastx_toolkit/0.0.13/devteam/package_fastx_toolkit_0_0_13/ec66ae4c269b/bin/fastx_barcode_splitter.pl line 22. BEGIN failed--compilation aborted at /galaxy/main/deps/fastx_toolkit/0.0.13/devteam/package_fastx_toolkit_0_0_13/ec66ae4c269b/bin/fastx_barcode_splitter.pl line 22."

Thanks in advance!

ADD COMMENTlink modified 4 weeks ago by Jennifer Hillman Jackson25k • written 4 weeks ago by e.bakhmet30
1
gravatar for Jennifer Hillman Jackson
4 weeks ago by
United States
Jennifer Hillman Jackson25k wrote:

UPDATE

This is a problem server side at Galaxy Main https://usegalaxy.org. An issue ticket has been created to track the correction, please follow for updates: https://github.com/galaxyproject/usegalaxy-playbook/issues/111

I am not sure yet if the dependency problem is present at the other usegalaxy server mirrors or not, but you could test the job there: https://galaxyproject.org/galaxy-updates/2018-04/#usegalaxyeu-and-usegalaxyorgau-launched

Thanks for reporting the problem!

ADD COMMENTlink modified 4 weeks ago • written 4 weeks ago by Jennifer Hillman Jackson25k

Confirmed: The workaround is to use the tool at the Galaxy Europe mirror at https://usegalaxy.eu/ for now.

This tool wrapper will be updated near-term and that will resolve this problem and similar related dependency problems at Galaxy Main https://usegalaxy.org

ADD REPLYlink written 26 days ago by Jennifer Hillman Jackson25k
0
gravatar for Jennifer Hillman Jackson
4 weeks ago by
United States
Jennifer Hillman Jackson25k wrote:

Hello,

It looks like there is at least one missing tool dependency. Specifically, the error references a Perl module that you may need to install. How to depends on your OS/platform - google for online install help or check here: http://www.microhowto.info/howto/install_a_perl_module.html

This is an older tool and not all dependencies are managed using the same methods that more current tools utilize. https://docs.galaxyproject.org/en/master/admin/dependency_resolvers.html

You might want to consider using the updated version of the tool https://toolshed.g2.bx.psu.edu/view/lparsons/fastx_barcode_splitter_enhanced/0fb7e9130a70. Make sure your Galaxy server is up to date first: https://docs.galaxyproject.org/en/master/releases/index.html

For the inputs, the barcode file should be formatted like this (quoted from the tool form):

Barcode file Format

Barcode files are simple text files. Each line should contain an identifier (descriptive name for the barcode), and 
the barcode itself (A/C/G/T), separated by a TAB character. Example:

#This line is a comment (starts with a 'number' sign)
BC1  GATCT
BC2  ATCGT
BC3  GTGAT
BC4 TGTCT

Thanks, Jen, Galaxy team

ADD COMMENTlink modified 4 weeks ago • written 4 weeks ago by Jennifer Hillman Jackson25k

Dear Jennifer,

I use galaxy in my browser, and process my data on galaxy-server. I can't find any buttons to manage versions of this tool.

ADD REPLYlink written 4 weeks ago by e.bakhmet30

What is the URL of the server? https://usegalaxy.org, https://usegalaxy.eu, or other?

If working at https://usegalaxy.org -- a bug report can be sent in. This might be a problem server-side.

Please leave all inputs/outputs undeleted and include a link to your Biostars post in the comments.

https://galaxyproject.org/issues/

ADD REPLYlink modified 4 weeks ago • written 4 weeks ago by Jennifer Hillman Jackson25k

My url is usegalaxy.org

ADD REPLYlink written 4 weeks ago by e.bakhmet30

Ok, then please send in a bug report. Thanks!

ADD REPLYlink written 4 weeks ago by Jennifer Hillman Jackson25k

Ok, thank You. Is usegalaxy.eu a newer server? Or are they a same?

ADD REPLYlink written 4 weeks ago by e.bakhmet30

The Galaxy Europe public server at https://usegalaxy.eu and the Galaxy / GVL 4.0.1 public server at https://usegalaxy.org.au are new mirrors for Galaxy Main at https://usegalaxy.org. Each is a distinct server and part of the core project.

Announcement: https://galaxyproject.org/news/2018-04-galaxy-update/

ADD REPLYlink written 4 weeks ago by Jennifer Hillman Jackson25k
1

Thank You very much! I'll send a report, but at the same time, I'll try to use galaxy.eu. May be there is no prolem at .eu server.

ADD REPLYlink written 4 weeks ago by e.bakhmet30

I'm doing some testing, too (at all of the servers). A bug report about the problem came in (it might be yours). I'll mark your question for an update about the solution. Feedback by end of week.

ADD REPLYlink written 4 weeks ago by Jennifer Hillman Jackson25k
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 121 users visited in the last hour