Question: BAM index file download leads to Server 500 error
0
gravatar for nicholas.provart
10 months ago by
nicholas.provart0 wrote:

I am trying to align reads to the TAIR10 Arabidopsis genome with TopHat v2.1.0 (I have an old protocol that uses this suite), and was in fact successful at generating BAM files. However, when I go to download the BAI index files, I get a Server 500 error. The UUID for the 4 analyses are

8ad6c1a7-9995-471f-bd86-a1b9ed7ac4c2, ac84ffa3-c88c-4542-9574-150b9f3d0fa3, 8f54476a-aeaa-4cf4-8cd9-fe83988a6e0c, and 1394bae2-e0c9-4032-92a1-b77f3cef56f8.

I am not able to use the right side bar to view the BAM files in IGB either (presumably because the BAI files are missing/corrupted). I've seen in other posts that Galaxy is supposed to automatically generate BAI files but what to do if it doesn't? Editing the metadata seems to call up a JSON string with lots of parameters in it, many of which don't seem to belong to me. It would be nice to have samtools index function to be able to recreate these BAI if necessary. Am I missing something?

Thanks!

tophat • 334 views
ADD COMMENTlink modified 10 months ago • written 10 months ago by nicholas.provart0
0
gravatar for Jennifer Hillman Jackson
10 months ago by
United States
Jennifer Hillman Jackson25k wrote:

Hello,

The problem is the job state with a metadata warning.

The solution is different than prior solutions. A copy of the dataset or the history is how to reset the metadata. This will allow you to use and download the data as normal.

This is a high priority fix for us, please see the full work-around and issue correction progress here: https://github.com/galaxyproject/usegalaxy-playbook/issues/62

Thanks for reporting the problem and our apologies for the current issues! Jen, Galaxy team

ADD COMMENTlink written 10 months ago by Jennifer Hillman Jackson25k
0
gravatar for nicholas.provart
10 months ago by
nicholas.provart0 wrote:

Hi Jen, thanks for the speedy response. Copying the history did not fix the issue. I'm still not able to download the BAM index files (*.bai) from the copied History, again because of a Server 500 errror. I was able to generate these using a local instance of samtools that we have running, so for me it's not a priority any more. It was just frustrating and for newbies would be doubly so. Perhaps this is only an issue with TopHat and not HISAT2? Best, Nick

ADD COMMENTlink written 10 months ago by nicholas.provart0

This is odd but thanks for the feedback. We're still working on the problem. And I'm going to take another look at your specific history/jobs. Please leave these undeleted for a few more minutes if you can.

ADD REPLYlink written 10 months ago by Jennifer Hillman Jackson25k

Ok, the copy is not enough (.bam downloads, but bam.bai give 500 error).

After the copy, click on the pencil icon to reach the Edit Attributes page then click on "autodetect metadata" and let that finish.

Once the metadata was reset, both the .bam and .bam.bai downloaded.

I'll update the workaround in the ticket to include this. Again, thanks for the followup!

ADD REPLYlink written 10 months ago by Jennifer Hillman Jackson25k
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 94 users visited in the last hour