Question: Installing Gemini tools
0
gravatar for kep
3 months ago by
kep10
United Kingdom
kep10 wrote:

Hi,

I'm trying to install the Gemini tools on a local galaxy instance (release 17.05) and am running into issuse, specifically that the gemini dependency of "package_gemini_0_18_1" fails to install.

It appears there are some dependencies of gemini which are installed through conda, however they have moved channels since 0.18.1 was released and the installer doesn't have the new channel as part of its search (see https://github.com/arq5x/gemini/commit/3744ec19d89ac988cbbeb1ed0893d59ed13323e9)

I can modify the installer as per that commit and run it again and it seems to install OK, however galaxy still thinks that the install is broken.

Looking at the IUC github pages there is work underway to move to a newer gemini release (which should have this fixed).

However, I was wondering if anyone here knew of a workaround to get gemini to install or, if not, convince galaxy all is OK when manually installing it.

Thanks Kev.

gemini • 174 views
ADD COMMENTlink modified 3 months ago • written 3 months ago by kep10
0
gravatar for Bjoern Gruening
3 months ago by
Bjoern Gruening4.8k
Germany
Bjoern Gruening4.8k wrote:

Hi, can you post the conda error which you get?

ADD COMMENTlink written 3 months ago by Bjoern Gruening4.8k

Hi, Bjoern

Please see below. This is for the gemini 0.18.1 package dependency of the 'package_gemini_0_18_1' repository.

From what I can tell it downloads the gemini 0.18.1 installer which is where the real issue lies as it doesn't have the conda-forge channel in its conda call. If I add it (as per the commit above) then it will install when I run it by hand.

Thanks Kev.

Error trimmed of miniconda download and with obfuscated install paths.

Python 2.7.11 :: Continuum Analytics, Inc. Error:  Dependency missing in current linux-64 channels:
  - gemini 0.18.1 py27_2 -> bottle

Did you mean one of these?

    bottleneck, bottlechest

You can search for this package on anaconda.org with

    anaconda search -t conda bottle

You may need to install the anaconda-client command line client with

    conda install anaconda-client Traceback (most recent call last):   File "./gemini/scripts/gemini_install.py", line 190, in <module>
    main(parser.parse_args())   File "./gemini/scripts/gemini_install.py", line 80, in main
    gemini = install_conda_pkgs(anaconda, remotes, args)   File "./gemini/scripts/gemini_install.py", line 104, in install_conda_pkgs
    subprocess.check_call([anaconda["conda"], "install", "--yes"] + channels + pkgs)   File "/usr/lib64/python2.7/subprocess.py", line 542, in check_call
    raise CalledProcessError(retcode, cmd) subprocess.CalledProcessError: Command '['<install path>/galaxy/database/dependencies/gemini/0.18.1/iuc/package_gemini_0_18_1/49de32b47548/anaconda/bin/conda', 'install', '--yes', '-c', 'bioconda', '--file', '_conda-requirements-0.18.1.txt']' returned non-zero exit status 1
ADD REPLYlink modified 3 months ago • written 3 months ago by kep10

Don't install the old packages anymore. Try to use Galaxy build in conda resolver to install gemini if possible. Please see here for more information: https://docs.galaxyproject.org/en/master/admin/conda_faq.html

ADD REPLYlink written 11 weeks ago by Bjoern Gruening4.8k

Hi Bjoern,

I was trying to install the 'gemini_*' tools from the admin web pages via the main tool shed. This error came about from that process. If this is not the best way to do it any more could you please advise what is.

As far as i can tell as I have had numerous other successful conda installs my copy of galaxy is setup to use conda.

Thanks Kev.

ADD REPLYlink written 10 weeks ago by kep10
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 74 users visited in the last hour