Question: Workflow won't run and can't be viewed
1
gravatar for deerussell
3 months ago by
deerussell10
deerussell10 wrote:

I am having an issue with two workflows, one that I generated today from a new history and one that was shared with me which I uploaded by URL to review. With both of them, I can edit them but I cannot view or run them on Galaxy Main. When I try to view them, I get the error: *This page isn’t working usegalaxy.org is currently unable to handle this request. HTTP ERROR 500* When I try to run them, I get a blank white page and nothing happens. I have 3 other workflows that I can view and run, so it seems to be specific to just the two.

The links to the two workflows with issues are as follows. https://usegalaxy.org/u/drussell/w/workflow-for-galaxy-course-project-imported-from-uploaded-file https://usegalaxy.org/u/drussell/w/workflow-constructed-from-history-triovariant-callingfinal-project

I know recently there was an issue with a single corrupted workflow that multiple people were having problems with, but the two workflows I am writing about are not the same as that one. ANd both of these workflows are saved in "Your Workflows" and are not in "Workflows Shared with you by Others".

Can someone please give me suggestions on what might be wrong and/or how to fix this?

workflow galaxy main • 175 views
ADD COMMENTlink modified 3 months ago by Jennifer Hillman Jackson23k • written 3 months ago by deerussell10

Hello - We are going to look into this. The problem is likely the same as in the other workflow (linked to deprecated tools, but we are checking).

A workaround, for now, might be the same as the other problematic workflow: Open the workflow in the editor and save it as a new renamed workflow. This corrects the metadata.

Let us know how that works and we will also get back to you after review.

Thanks, Jen, Galaxy team

ADD REPLYlink written 3 months ago by Jennifer Hillman Jackson23k

Can you export these workflows to a file?

ADD REPLYlink written 3 months ago by aysam.guerler70
0
gravatar for Jennifer Hillman Jackson
3 months ago by
United States
Jennifer Hillman Jackson23k wrote:

Update:

I can see that your "Save As" test made the second workflow able to be 1) run 2) shared. Do that with both so you can use them now.

Aysam and I will work together on more troubleshooting. If/when we end up creating a ticket or a pull-request change, one of us will link that back here. We now have downloaded .ga copies of one of the problematic workflows (original and resaved), so you don't need to do that.

If anyone else runs into a problem with imported or uploaded workflows that produces this error (unable to run or share) - do the same action - open the workflow in the editor and use the function "Save As" to create a copy that can be used.

Thanks! Jen, Galaxy team

ADD COMMENTlink written 3 months ago by Jennifer Hillman Jackson23k
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 86 users visited in the last hour