Question: fastqc not found
0
gravatar for heidi.hough
7 months ago by
heidi.hough0 wrote:

I'm having a problem with fastqc. I don't understand why it claims not to be found. What am I missing?

Fatal error: Exit code 1 ()
/bin/sh: 1: fastqc: not found
Traceback (most recent call last):
  File "/main/sites/galaxy/galaxy/shed_tools/toolshed.g2.bx.psu.edu/repos/devteam/fastqc/9337dd1fbc66/fastqc/rgFastQC.py", line 170, in <module>
    fastqc_runner.run_fastqc()
  File "/main/sites/galaxy/galaxy/shed_tools/toolshed.g2.bx.psu.edu/repos/devteam/fastqc/9337dd1fbc66/fastqc/rgFastQC.py", line 142, in run_fastqc
    subprocess.check_call(self.command_line, shell=True)
  File "/usr/lib/python2.7/subprocess.py", line 541, in check_call
    raise CalledProcessError(retcode, cmd)
subprocess.CalledProcessError: Command 'fastqc --outdir /main/sites/galaxy/galaxy/htdocs/database/jobs_directory/000/57/dataset_113_files --quiet --extract -f fastq DRR016125_1_1percent_fastq' returned non-zero exit status 127
fastqc local galaxy • 296 views
ADD COMMENTlink modified 7 months ago by Jennifer Hillman Jackson23k • written 7 months ago by heidi.hough0

You did not tell us what you have so it is difficult to tell you what is missing. What Galaxy and what version of Galaxy is this? Does it use Conda? Are you an admin? Have the fastqc ever worked? Do other tools with dependencies work?

ADD REPLYlink written 7 months ago by Martin Čech ♦♦ 4.3k

I should have clarified this is on a local installation of 17.01. Conda is in use and I am an admin.

I have been able to confirm this is related to our cluster. I suspect something is wrong with the job_conf.xml.

<job_conf> <plugins> <plugin id="local" type="runner" load="galaxy.jobs.runners.local:LocalJobRunner" workers="4"/> <plugin id="drmaa" type="runner" load="galaxy.jobs.runners.drmaa:DRMAAJobRunner"/> </plugins> <handlers> <handler id="main"/> </handlers> <destinations default="SGE"> <destination id="local" runner="local"/> <destination id="SGE" runner="drmaa"/> <param id="embed_metadata_in_job">False</param> <env file="/main/sites/galaxy/galaxy/htdocs/.venv/bin/activate"/> </destinations> </job_conf>

ADD REPLYlink written 7 months ago by heidi.hough0
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 122 users visited in the last hour