Question: I used tophat and give mistake Error: segment-based junction search failed with err =-5
0
gravatar for knarf0506
5 months ago by
knarf05060
knarf05060 wrote:

In my local galaxy , I used Tool Shed TopHat Gapped-read mapper for RNA-seq data (Galaxy Version 2.1.1),they need Dependency Resolver Details :

Dependency Version Resolver Exact version Current Installation Status bowtie2 2.2.8 Galaxy_Package True
tophat 2.1.1 Galaxy_Package True

I prepared,and the following is the wrong question

<h6>################ By Message</h6>

Fatal error: Tool execution failed Building a SMALL index

[2017-02-16 15:06:47] Beginning TopHat run (v2.1.1)

[2017-02-16 15:06:47] Checking for Bowtie Bowtie version: 2.2.8.0 [2017-02-16 15:06:47] Checking for Bowtie index files (genome).. [2017-02-16 15:06:47] Checking for reference FASTA file [2017-02-16 15:06:47] Generating SAM header for genome [2017-02-16 15:06:47] Preparing reads left reads: min. length=75, max. length=75, 100 kept reads (0 discarded) right reads: min. length=75, max. length=75, 100 kept reads (0 discarded) [2017-02-16 15:06:47] Mapping left_kept_reads to genome genome with Bowtie2 [2017-02-16 15:06:47] Mapping left_kept_reads_seg1 to genome genome with Bowtie2 (1/3) [2017-02-16 15:06:47] Mapping left_kept_reads_seg2 to genome genome with Bowtie2 (2/3) [2017-02-16 15:06:47] Mapping left_kept_reads_seg3 to genome genome with Bowtie2 (3/3) [2017-02-16 15:06:47] Mapping right_kept_reads to genome genome with Bowtie2 [2017-02-16 15:06:47] Mapping right_kept_reads_seg1 to genome genome with Bowtie2 (1/3) [2017-02-16 15:06:48] Mapping right_kept_reads_seg2 to genome genome with Bowtie2 (2/3) [2017-02-16 15:06:48] Mapping right_kept_reads_seg3 to genome genome with Bowtie2 (3/3) [2017-02-16 15:06:48] Searching for junctions via segment mapping [FAILED] Error: segment-based junction search failed with err =-5 Reason: image not found

can someone help me this question ? Appreciate !!! :) by ru-feng

tophat bowtie galaxy • 170 views
ADD COMMENTlink modified 5 months ago • written 5 months ago by knarf05060
0
gravatar for Jennifer Hillman Jackson
5 months ago by
United States
Jennifer Hillman Jackson22k wrote:

Hello,

As far as I can tell, the error is with this specific version of Tophat when run on MAC OSX when the junction search option is used. A google for the error shows that many have run into this even when running the tool line command (outside of Galaxy).

This indicates that this is not a Galaxy-specific issue, may be related to dependencies, and has been around a while - forum comments and solutions vary but most conclude that there is a problem with this version of the Tophat binary itself.

You could try installing an earlier version of the tool to see if that resolves the problems. It has for some. Or run the tool without the junction coverage search.

If there is more to this, we will post an update. Others are also welcome to comment/post more feedback.

Thanks! Jen, Galaxy team

ADD COMMENTlink written 5 months ago by Jennifer Hillman Jackson22k
0
gravatar for knarf0506
5 months ago by
knarf05060
knarf05060 wrote:

Ok ! I will try it If I have any problems and trouble you again ! Thank you :) , Best Team !

ADD COMMENTlink written 5 months ago by knarf05060
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 56 users visited in the last hour