Question: Changing the command syntax of a tool in xml (changed are not applied)
0
gravatar for vebaev
10 months ago by
vebaev130
Bulgaria
vebaev130 wrote:

Hi,

I'm trying to change the XML of the tool since in the field <command> the syntax is wrong and the tool produced an empty file. I have changed the XML saved it, reload the XML in the Galaxy (the tool page is the new so the Galaxy loads the modifications).

Nevertheless, the job failed as before and when I go to information icon of the output the "Job Command-Line:" shows again the old wrong syntax?

Am I doing something wrong?

tool xml • 270 views
ADD COMMENTlink modified 10 months ago by y.hoogstrate450 • written 10 months ago by vebaev130

Make sure, not to use the "Run this job again" button, but rather select the tool from the tool list again and run it.

Regards, Hans-Rudolf

ADD REPLYlink written 10 months ago by Hotz, Hans-Rudolf1.7k

Yes I select the tool from the tool list, also I modified the tool help in the xml and I see the monifications on the loaded page, but after starting the command ("Job Command-Line:" ) that was run seems the old, I cannot explained?.... I have recheck the xnl and the command is the new....

ADD REPLYlink written 10 months ago by vebaev130

what happens, when you give the tool a new version?

ADD REPLYlink written 10 months ago by Hotz, Hans-Rudolf1.7k

When I edit the tool version from 1.0.0 to 1.0.1, I see when I load the tool at the top 1.0.1 but the executed command remains the old one, nevertheless the both changes are in the same xml.

ADD REPLYlink written 10 months ago by vebaev130

and when you now check the entry in the 'job' table for this job, what is the value of "tool_version" ?

ADD REPLYlink written 10 months ago by Hotz, Hans-Rudolf1.7k
0
gravatar for y.hoogstrate
10 months ago by
y.hoogstrate450
Netherlands
y.hoogstrate450 wrote:

Planemo makes development very easy: http://galaxyproject.github.io/training-material//Dev-Corner/slides/tool_integration#41

ADD COMMENTlink written 10 months ago by y.hoogstrate450

I'm not developing tool, this is already developed tool in the toolshed, unfortunately the syntax in the wrapper is wrong, which executes the binary executable of the tool file.

ADD REPLYlink written 10 months ago by vebaev130
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 94 users visited in the last hour