Question: Filezilla FTP fails with error "ECONNREFUSED - Connection refused by server"
0
gravatar for a.turtoi
2.0 years ago by
a.turtoi • 50
a.turtoi • 50 wrote:

Hi Everybody,

I am unable to upload my files using FileZila FTP client on Galaxy....

The error message is:

Status: Resolving address of usegalaxy.org

Status: Connecting to 129.114.60.179:21...

Status: Connection attempt failed with "ECONNREFUSED - Connection refused by server", trying next address.

Status: Connecting to 129.114.60.180:21...

Status: Connection attempt failed with "ECONNREFUSED - Connection refused by server".

Error: Could not connect to server

ADD COMMENT • link • modified 22 months ago by domantas.gudeliauskas • 0 • written 2.0 years ago by a.turtoi • 50
0
gravatar for Jennifer Hillman Jackson
2.0 years ago by
United States
Jennifer Hillman Jackson ♦ 25k wrote:

Hello,

This specific error indicates that there may be a firewall problem on your side.

This prior Q&A at another board covers the details: http://stackoverflow.com/questions/12687900/connection-attempt-failed-with-econnrefused-connection-refused-by-server

Hopefully this helps lead to a solution for you, Jen, Galaxy team

ADD COMMENT • link modified 2.0 years ago • written 2.0 years ago by Jennifer Hillman Jackson ♦ 25k
0
gravatar for a.turtoi
2.0 years ago by
a.turtoi • 50
a.turtoi • 50 wrote:

Dear Jennifer,

This might be indeed the issue. May I ask you if it is correct to write in FileZila as host sftp://usegalaxy.org) if we want to switch to sftp server?

If yes I am still getting an error message:

Status: Connecting to usegalaxy.org...

Response: fzSftp started, protocol_version=6

Command: open "a.turtoi@ulg.ac.be@usegalaxy.org" 22

Error: Socket is not connected

Error: Could not connect to server

ADD COMMENT • link written 2.0 years ago by a.turtoi • 50

Galaxy does not support SFTP by default. This is cause of the current issue/error above.

Use passive FTP at http://usegalaxy.org. Enter the server name as just "usegalaxy.org" and adjust the Filezilla settings as needed.

ADD REPLY • link modified 2.0 years ago • written 2.0 years ago by Jennifer Hillman Jackson ♦ 25k
0
gravatar for a.turtoi
2.0 years ago by
a.turtoi • 50
a.turtoi • 50 wrote:

Dear Jenny,

I agree, it is the internal firewall. I am already using passive FTP but this does not solve the problem. Before going to IT people, do you have another idea how to overcome the issue?

Best regards, Andrei

ADD COMMENT • link modified 2.0 years ago • written 2.0 years ago by a.turtoi • 50

The firewall could still be the block, even when passive FTP is used. Getting help/clarification from your IT group is a good idea - they might be willing to clear up access to http://usegalaxy.org specifically.

ADD REPLY • link written 2.0 years ago by Jennifer Hillman Jackson ♦ 25k
0
gravatar for domantas.gudeliauskas
22 months ago by
domantas.gudeliauskas • 0 wrote:

I was also getting this error message, tried switching between active / passive modes, changing port, restarting router. The only thing that helped me was reconfiguring FileZilla Network Configuration Wizard as per instructions I found here.

ADD COMMENT • link written 22 months ago by domantas.gudeliauskas • 0
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 182 users visited in the last hour