Question: Missing tool dependences with gray install box (Mothur tool)
0
gravatar for vebaev
2.4 years ago by
vebaev130
vebaev130 wrote:

Hi, I'm trying to install from tool shed Mothur but every time I got missing tool depenences:

Mothur v1.33 metagenomics tools, Owner jjohnson I have tried several Revision of the tool in the tool shed but the result is the same.

What should I do in order to install it correct?

missing dependences mothur • 937 views
ADD COMMENTlink modified 2.3 years ago by ps25360 • written 2.4 years ago by vebaev130
1
gravatar for Jennifer Hillman Jackson
2.4 years ago by
United States
Jennifer Hillman Jackson25k wrote:

Hello,

This version of the wrapped tool does not have linked dependencies (this message appears in the Tool Shed when the repository is viewed: http://usegalaxy.org/toolshed).

Instead, try the version by GVL: https://toolshed.g2.bx.psu.edu/view/qfab/package_mothur/150982d8fd53

Thanks, Jen, Galaxy team

ADD COMMENTlink written 2.4 years ago by Jennifer Hillman Jackson25k

Thanks, one quick question on installation it does not ask in which category in the side bar to be installed? So it does not show anywhere on the left tools bar in Galaxy?

ADD REPLYlink written 2.4 years ago by vebaev130
1
gravatar for Saskia Hiltemann
2.4 years ago by
Saskia Hiltemann70 wrote:

hmm, this worked for me not too long ago, I'll see if I can test it again soon, do you get any error message?

ADD COMMENTlink written 2.4 years ago by Saskia Hiltemann70
1

Yes, I have uninstalled it, but it was something like file not found or missing file. I have tried it 3-4 times with same output.

ADD REPLYlink modified 2.4 years ago • written 2.4 years ago by vebaev130

hmm, this seems to be a problem with the blast package (package_blast_2_2_26) in the tool shed. The files it tries to download from ncbi seem to have moved (e.g. ftp://ftp.ncbi.nlm.nih.gov/blast/executables/release/LATEST/blast-2.2.26-x64-linux.tar.gz, which doesn't exist anymore)

ADD REPLYlink modified 2.4 years ago • written 2.4 years ago by Saskia Hiltemann70

Hi, I have tried to install again 1.33 in the toolshed but had multiple units with missing dependencies....

ADD REPLYlink written 21 months ago by vebaev130
0
gravatar for y.hoogstrate
2.4 years ago by
y.hoogstrate460
Netherlands
y.hoogstrate460 wrote:

Hello manekineko,

A college of mine is working really really hard to update all wrappers to make them in line with the iuc standards and to make them depend on the bioconda dependency. Because we're talking about 113 tools it is taking a while but she's already quite far. You can follow the progress at the following url: https://github.com/galaxyproject/tools-iuc/pull/671 don't worry to give feedback and when it's ready don't be shy to test.

Great to see there is interest in these tools!

Youri

ADD COMMENTlink modified 2.4 years ago • written 2.4 years ago by y.hoogstrate460
0
gravatar for ps2536
2.3 years ago by
ps25360
ps25360 wrote:

I am a total newbie with commands etc. I have a local install of Galaxy. How do I install the Mothur toolsuite? Is this even working? Am I wasting my time ?

Whatever is available in the Main tool shed never really installs, I just get an error:

Mothur v1.33 metagenomics tools jjohnson 040410b8167e Installed, missing tool dependencies

I am totally clueless, and a step-by-step would be helpful.

ADD COMMENTlink written 2.3 years ago by ps25360
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 161 users visited in the last hour