Question: Using Annovar in a Workflow
2
gravatar for christophe.habib
2.6 years ago by
France
christophe.habib340 wrote:

Hello everyone,

I would like to use Annovar (developed by the devteam) in a workflow. To do so I need to specify several databases in the Annotation Databases field. Unfortunately I can't manage to find how to do it properly.

  • DBname1-DBname2
  • DBname1,DBname2
  • DBname1\nDBname2
  • many other attempt

All this things do not work since the wrapper is looking for hg19_DBname1-DBname2.txt and so on.

I think that the problem comes from the fact that the Annotation Databases selection is done through an interactif field.

I hope someone know how to select several databases, that would be really useful.

Thank you,

Christ

workflow annovar database • 1.5k views
ADD COMMENTlink modified 2.5 years ago by aysam.guerler90 • written 2.6 years ago by christophe.habib340

Hi Jen,

I saw your reply on my email but I can't see it here anymore. Just to answer you, the wrapper does support multi-DB selection. The issue here is that it doesn't work when you include the tool in a workflow where you want to select 2 or 3 DB for annotation.

I hope someone found how to properly specify the DBs in the workflow..

Best regards,

Christ

ADD REPLYlink written 2.5 years ago by christophe.habib340
1
gravatar for aysam.guerler
2.5 years ago by
United States
aysam.guerler90 wrote:

Hi Christ,

Thanks for reporting this. Have you tried to separate the database by new lines like shown here: http://imgur.com/Ubtbp79.

ADD COMMENTlink modified 2.5 years ago • written 2.5 years ago by aysam.guerler90

Yes I did, that is what I meant when I wrote DBname1 \n DBname2 ;) Here is an example of the log with exac03 and cosmic70 :

Log: tool progress
Error: the required database file /DATAS/user/galaxy/tool-data/annovarDB/hg19/hg19_exac03__cn__cosmic70.txt does not exist.
cp: impossible d'évaluer « output.hg19_multianno.vcf »: Aucun fichier ou dossier de ce type

As you see, he is looking for a file with both names instead of 2 files with the differents names.

ADD REPLYlink written 2.5 years ago by christophe.habib340

I confirm that is what I did in the Annotation Databases field.

ADD REPLYlink modified 2.5 years ago • written 2.5 years ago by christophe.habib340

when I clic on run this job again I can read this :

"An invalid option was selected for filters, 'exac03\ncosmic70', please verify."
ADD REPLYlink written 2.5 years ago by christophe.habib340

Can you please post the version you are using? I could not find 08b003ee9db7

ADD REPLYlink written 2.5 years ago by aysam.guerler90

It is the revision number I have in my toolshed repository. Here is the header of the wrapper.

<tool id="table_annovar" name="ANNOVAR Annotate VCF" version="0.2">

And when I try to get update It says that it is the current version.

ADD REPLYlink modified 2.5 years ago • written 2.5 years ago by christophe.habib340

Thanks, and which Galaxy version you are using?

ADD REPLYlink modified 2.5 years ago • written 2.5 years ago by aysam.guerler90

Sorry for taking this long to answer. I was on 15.01. But the issue is kind of "solved". When you observe it you need to delete the box in the workflow interface and to create it again. But this bug is not reproducible : I didn't find any clue about "when" this bug occurs on a given workflow, "why" this bug was still here when the workflow was shared and "why" delete/recreate the box solved the problem. I upgraded Galaxy to 16.01, if I observe this bug again I will let you know ! Thanks !

ADD REPLYlink written 2.5 years ago by christophe.habib340
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 128 users visited in the last hour