Question: Tophat keeps failing
0
gravatar for alexsalam
2.7 years ago by
alexsalam • 0
alexsalam • 0 wrote:

Hi, since yesterday Tophat on the galaxy server keeps returning error messages or turning green as if completed (but it obviously hasn't as the file size is too small). Examples of error messages are:

'This job failed for reasons that could not be determined. Please click the bug icon to report this problem if you need help.'

'File "/galaxy-repl/instances/main/server/lib/galaxy/jobs/runners/util/job_script/__init__.py", line 101, in write_script f.write(contents) IOError: [Errno 28] No space left on device'

'IOError: [Errno 32] Broken pipe close failed in file object destructor: IOError: [Errno 28] No space left on device'

'Error: segment-based junction search failed with err =1 [bam_header_read] invalid BAM binary header (this is not a BAM file).'

I have plenty of space left on the server, am only running this job, the files are about 6 GB x 2.

Is this is an issue with the server?

Thanks,

Alex

tophat • 884 views
ADD COMMENT • link • modified 2.7 years ago by Jennifer Hillman Jackson ♦ 25k • written 2.7 years ago by alexsalam • 0

Hi Alex,

Did you check if all your filesystems have free space left ? For example the /tmp, /run or any other one ?

ADD REPLY • link written 2.7 years ago by christophe.habib • 340

thanks christophe. not quite sure what you mean, as I am using the public galaxy server. I am using 150 Gb out of the 250 available.

ADD REPLY • link written 2.7 years ago by alexsalam • 0

My bad, I thought you were using your own local instance. Maybe it could be related to an issue with the disk usage calculation.

ADD REPLY • link written 2.7 years ago by christophe.habib • 340

thanks. how would i resolve that issue if that’s the case? Of note under user preferences it says 'You are using 94.6 GB of disk space in this Galaxy instance’, although in my history it says 150 GB. not sure why there is this discrepancy.

ADD REPLY • link written 2.7 years ago by alexsalam • 0

There is a current issue with Main that the team is investigating. More feedback soon. Thanks for your patience. Jen, Galaxy team

ADD REPLY • link written 2.7 years ago by Jennifer Hillman Jackson ♦ 25k
0
gravatar for Jennifer Hillman Jackson
2.7 years ago by
United States
Jennifer Hillman Jackson ♦ 25k wrote:

Hello,

The recent tool failures due to the cluster issues are now cleared. Please re-run the failed job(s) and let us know if problems persist via a new bug report from the latest failure (from today). We can help to diagnose the issue and get it resolved.

Thank you all again for your patience while we worked on the solution, Jen, Galaxy team

Ps: The space issue was on the cluster. This is independent of the work space in your own account.

ADD COMMENT • link written 2.7 years ago by Jennifer Hillman Jackson ♦ 25k
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 169 users visited in the last hour