Question: Paired-end dataset collection with Bowtie2
0
gravatar for brigida.rusconi
2.9 years ago by
United States
brigida.rusconi40 wrote:

Hi,

I made a paired-end fastqsanger dataset collection and tried to run it with Bowtie2, but it doesn't recognize the input files. Is that functionality of the tool really working or is it still in testing? I have also tried to use it with BWA and tophat and never got anything. I am wondering how it assigns the forward and reverse when the input is a list. I could not see how it assigns them in the wrapper.

Best,

Brigida Rusconi

 

bowtie collection • 1.0k views
ADD COMMENTlink modified 2.9 years ago by Jennifer Hillman Jackson25k • written 2.9 years ago by brigida.rusconi40
0
gravatar for Jennifer Hillman Jackson
2.9 years ago by
United States
Jennifer Hillman Jackson25k wrote:

Hello,

My guess is that the data is in a collection, but not a paired-end collection (the 3rd type). When building the paired list, orientation of the pairs is specified, and then that is interpreted by tools downstream.

Double check these two things:

1. The dataset collection was created with the option "Build list of dataset pairs". This creates a paired-end collection. 

2. The target tool form has the input type selected as "Paired-End Dataset Collection". 

 

Best, Jen, Galaxy team

ADD COMMENTlink written 2.9 years ago by Jennifer Hillman Jackson25k

Hi,

I have done both as described above. It starts the Bowtie2, but when I look at the information and it says no dataset collection.

1. paired dataset collection link: https://www.dropbox.com/s/ovt3rzc69hesmns/Screenshot%202015-10-14%2012.49.58.png?dl=0

2. Bowtie2 settings link: https://www.dropbox.com/s/57ac3v6hmke9udf/Screenshot%202015-10-14%2012.50.39.png?dl=0

3. Bowtie2 info link: https://www.dropbox.com/s/chmjk7s1wy828o0/Screenshot%202015-10-14%2012.51.42.png?dl=0

The admin checked and it looks like Bowtie2 isn't starting it just stays in the currently running status, without actually running. I am not using fastqgroomer to prepare my files since they already have the sanger quality scores. I simply change the extension to fastqsanger.

 

ADD REPLYlink written 2.9 years ago by brigida.rusconi40

I tried again and it looks like I was not waiting long enough for it to finish. I was thrown off by the info saying no dataset collection. Thanks for the help.

ADD REPLYlink written 2.9 years ago by brigida.rusconi40

Ok, this makes sense if the info page screenshot was from when the job was still queued/executing. I thought the problem was with the tool form entry itself (before submission, meaning recognizing datasets from the history to be selected). But glad all is working! Jen

ADD REPLYlink written 2.9 years ago by Jennifer Hillman Jackson25k
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 113 users visited in the last hour