Question: Freebayes issue on merged data
2
gravatar for hamaisa
2.4 years ago by
hamaisa20
hamaisa20 wrote:

Hi,

I am completely new to this field so I'm hoping this is a simple mistake on my part.

I'm trying to find the number of SNPs, indels and MNPs in a merged data set I have on Galaxy. This merged data set consists of 3 pairs of paired ended data and before merging, I have preprocessed the data (FastQC Read, FASTQ Groomer), mapped the data with BWA for Illumina, filtered my SAM files and specified read groups before variant calling.

When I try to run the Freebayes tool on the merged data set, I encounter the following error message: Fatal error: Exit code 1 () unable to find FASTA index entry for ''

I searched this forum for a similar request and I believe I am using the right reference genome (hg19) and have consistently used this genome throughout my analysis: Need help with "VCFgenotype-to-haplotype:" tool

Any assistance for this issue is appreciated!

 

ADD COMMENTlink modified 2.4 years ago • written 2.4 years ago by hamaisa20
2

Hi 

While I do not know what the specific error is caused by.  I suspect that it is not due to merging, I run the same steps including merging bam files and I have no problem wit Freebayes.  Do you get the same problem if input multiple bam files into freebayes rather than a single merged one  (it is not limited to taking a single input file)? Thanks Guy

 

ADD REPLYlink written 2.4 years ago by Guy Reeves1.0k
1
gravatar for Jennifer Hillman Jackson
2.4 years ago by
United States
Jennifer Hillman Jackson23k wrote:

Hello,

This is just a guess, but have you tried re-sorting the BAM files then merging them? Most of the mappers sort now, but some downstream tools need to have the BAMs sorted again with the distinct Galaxy tool Picard > SortSam. (By coordinate, otherwise the tools will error in some way about sorting or the ref genome - the error you posted looks as if it could be reference genome related). I would even test out sorting then loading as individual datasets (if going straight to loading as individual datasets fails in the test Guy suggests). 

If all of this is still problematic, please share a link to the history, along with a link to this post, to galaxy-bugs@lists.galaxyproject.org. The work must be on http://usegalaxy.org (Galaxy Main) to share it this way. If not working on Main, is it reproducible there? Could be another clue if not.

Thanks! Jen, Galaxy team

ADD COMMENTlink written 2.4 years ago by Jennifer Hillman Jackson23k
0
gravatar for hamaisa
2.4 years ago by
hamaisa20
hamaisa20 wrote:

Hi,

Thank you for your suggestions!

I get the same problem (error message), when I input multiple BAM files into FreeBayes rather than the merged one file.

I also tried sorting the individual BAM files with SortSam before applying FreeBayes and I get the same error message.

I even tried removing PCR duplicates using the Mark Duplicates tool on the sorted data and FreeBayes gives me the same error.

I have shared a link to the work history and emailed this to galaxy-bugs@lists.galaxyproject.org as you've suggested.

 

Thank you again!


 

ADD COMMENTlink modified 2.4 years ago • written 2.4 years ago by hamaisa20
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 57 users visited in the last hour