Question: Disk quota at 100% when I believe it should be less than 50%
0
gravatar for Eric A. Wold
2.6 years ago by
United States
Eric A. Wold0 wrote:

Hello!

My tools are frozen due to an allocation issue. My quota is showing over 100% and I believe that is incorrect. When everything was permanently deleted it still showed 73% full, with nothing on the disk. 

Thank you for the help!

Best, Eric

rna-seq software error galaxy • 1.6k views
ADD COMMENTlink modified 15 months ago by fukunaga10 • written 2.6 years ago by Eric A. Wold0
1
gravatar for Dannon Baker
2.6 years ago by
Dannon Baker3.7k
United States
Dannon Baker3.7k wrote:

Should be fixed now, thanks!

ADD COMMENTlink written 2.6 years ago by Dannon Baker3.7k

Awesome, thank you Dannon!

ADD REPLYlink written 2.6 years ago by Eric A. Wold0

Dear Dannon,

I am having the same problem as Eric, I had permanently deleted files and purged histories to free up space, two weeks ago. I should be using about 130 GB storage, but still Galaxy tells me I am over 100% and am unable to unpause my workflows. Can you please take a look into that?  

ADD REPLYlink written 2.5 years ago by Felix Mayr10

Taken care of, thanks!

ADD REPLYlink written 2.5 years ago by Dannon Baker3.7k

Thanks! Whatever you did worked and I ran two samples, one which worked out great, the other did make a mistake and I want to run again. However, now I have the same problem, after permanently deleting the files and purging those histories the disk allocation didnt change as much as it should have. Could you take a look at it again? Is there something that I can do to circumvent this problem? My next two runs are now on pause..

Thanks a lot in advance,

Felix

ADD REPLYlink written 2.5 years ago by Felix Mayr10

Hi Dannon, 

I haven't had a reply on my last message. I am still unrightfully over my disk quota and can't do anything on Galaxy......

Best, Felix

ADD REPLYlink written 2.5 years ago by Felix Mayr10

Hey Felix, fixing it now.

ADD REPLYlink written 2.5 years ago by Dannon Baker3.7k

Thank you, worked. 

ADD REPLYlink written 2.5 years ago by Felix Mayr10

Hi Dannon,

The last time I removed and purged data, disk quota was freed up immediately (which was a first), so what you did seems to have worked. However, there is still 20% disk quota allocated to some ghost files. I have clearup up all my histories and data, but it stays at 20%. 

I am uploading 2 samples now to the FTP server, so it would be great if the disk quota is cleared up before I start my workflows :-) 

Thanks in advance! 

Felix

ADD REPLYlink written 2.4 years ago by Felix Mayr10

I actually ran our recalculation procedure for *everyone* today since we just updated the Galaxy server.  You should have your correct usage and it should stay that way from here on out.

ADD REPLYlink written 2.4 years ago by Dannon Baker3.7k

Dear Dannon,

May I have my disk space re-checked?  I have deleted everything despite 49% being in use.  I have discovered that this is due to deleting data by: 1) deleting history completely under history options without manually purging each individual file and 2) using purge history feature under multi-history view without manually purging the files.

I will refrain from using these two methods in the future.

Thank you very much in advance!

ADD REPLYlink written 2.5 years ago by enza.vernucci10
1

Hi, done!

I'll doublecheck both of these methods you've used, but I believe I fixed the bug in the underlying framework that causes this.  The change has not propagated to usegalaxy.org yet, but will soon, and you won't have to worry about this anymore.

ADD REPLYlink written 2.4 years ago by Dannon Baker3.7k
1
gravatar for fukunaga
15 months ago by
fukunaga10
United States
fukunaga10 wrote:

No the issue is not solved yet. It still shows usage is 100% and I am over disk quota, although I'm using only 124GB.

ADD COMMENTlink written 15 months ago by fukunaga10

Hello,

Please send an email from the same address as used for your Galaxy account with the problem to galaxy-bugs@lists.galaxyproject.org. We cannot help without that information and a direct email from the registered Galaxy account email address. This is to protect your account privacy and to ensure we are looking at the correct account.

Include a link to the shared history, if there is one that shows job delays/warning message about being over account data usage quota. This is how to generate one: https://wiki.galaxyproject.org/Learn/Share. Be sure to leave all inputs and latter tool error datasets displaying error undeleted.

Also include a link to this Biostars post so we can link the two items together.

Thanks, Jen, Galaxy team

ADD REPLYlink modified 15 months ago • written 15 months ago by Jennifer Hillman Jackson23k
0
gravatar for Felix Mayr
2.5 years ago by
Felix Mayr10
Germany
Felix Mayr10 wrote:

Hi Dannon,

I keep running into the same problem. Can I get a shorter line with you so that I can notify you when the disk quota is wrongfully over its limit? Right now it is at 73%, while I have only loaded public data in my one and only history... I will probably need more than 27% disk quota to run another sample, so if you would kindly free up my quota again, that would be great!! 

Thanks in advance,

Felix

ADD COMMENTlink written 2.5 years ago by Felix Mayr10
1

I've recalculated your usage and you're good to go now.  I believe I've fixed the underlying issue and once the change makes it to the main server (probably after GCC) we shouldn't have this happen anymore.  If you do need help again before that happens, certainly feel free to reply here and I'll get right to it.

ADD REPLYlink written 2.4 years ago by Dannon Baker3.7k

Hi Dannon,

I am having a similar issue, my account continues to show that I am over the quota even after data sets are permanently deleted. Could you please take a look at my quota?

Thanks,

Lewis

ADD REPLYlink written 2.4 years ago by lewis.entwistle0

Commented on the other post, but for completeness -- recalculated, you're good to go now.

ADD REPLYlink written 2.4 years ago by Dannon Baker3.7k

Hi Dannon,

this seems to be a quite frequent thing, happened to me this morning... could you look at my quota as well, please? My account goes by the email adress <removed by admin>

ADD REPLYlink modified 2.4 years ago by Martin Čech ♦♦ 4.2k • written 2.4 years ago by fgrosseholz0

Dear good sir,

this has been done.

Thank you for using Galaxy

ADD REPLYlink written 2.4 years ago by Martin Čech ♦♦ 4.2k

Thanks a million!

ADD REPLYlink written 2.4 years ago by fgrosseholz0
0
gravatar for fukunaga
15 months ago by
fukunaga10
United States
fukunaga10 wrote:

Hi Dannon,

I am having a similar issue. My account shows that I am over the quota even though I'm using less than 125GB which is less than half of the allowed 250GB. Could you please take a look at my quota?

ADD COMMENTlink written 15 months ago by fukunaga10

The account linked with your Biostars account only shows usage at 7.4 GB. Recalculating did not change this. Perhaps the issue was already corrected?

Jen, Galaxy team

ADD REPLYlink written 15 months ago by Jennifer Hillman Jackson23k

No. The issue was not solved yet. It still says I'm over the quota, and shows 100% usage, although I'm using only 124 GB and have purged all of the deleted datasets. Could you please look? I'm talking about the account whose login name is my email address.

ADD REPLYlink written 15 months ago by fukunaga10

I recalculated your usage and it remains at 251.9 GB. Can you check for deleted but not yet purged datasets and histories?

ADD REPLYlink written 15 months ago by Dannon Baker3.7k

I checked again and confirmed that all the deleted datasets and histories have been purged.

Just now I deleted and purged everything. It shows zero b. But it is still showing that I'm using 50% of my quota. So it seems there is unseeable, undeletable, unpurgable 125GB data in this account?

ADD REPLYlink written 15 months ago by fukunaga10

Can you go to https://usegalaxy.org/history/list, click 'advanced search', and then 'deleted', to verify there are no 'deleted' but not 'deleted permanently' histories?

ADD REPLYlink written 15 months ago by Dannon Baker3.7k

There was a deleted but not deleted permanently history when I followed that you suggested. When I permanently deleted it, it solved the issue. Thank you very much!

ADD REPLYlink written 15 months ago by fukunaga10
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 84 users visited in the last hour