Question: cummerbund installation error- R package version
1
gravatar for jashapiro
2.3 years ago by
jashapiro10
United States
jashapiro10 wrote:

The current version of cummerbund in the toolshed (package_cummerbund_2_8_2) has a dependency on the R digest package, which it specifies to download from http://cran.r-project.org/src/contrib/digest_0.6.7.tar.gz , The R package has recently been updated to 0.6.8, so the url is no longer valid, and the cummerbund package fails to install. 

Is there a simple way to specify the updated url in the package? 

Update: I see that this is updated in the github repository: 

https://github.com/galaxyproject/tools-iuc/blob/master/packages/package_cummerbund_2_8_2/tool_dependencies.xml

How long does it generally take for such updates to propagate to the toolshed?

toolshed software error • 1.2k views
ADD COMMENTlink modified 2.3 years ago by Dave B.380 • written 2.3 years ago by jashapiro10
3
gravatar for Dave B.
2.3 years ago by
Dave B.380
United States
Dave B.380 wrote:

Thanks for the notification, I've corrected the dependency and the cummerbund library should now install correctly.

ADD COMMENTlink written 2.3 years ago by Dave B.380

Thanks, but sadly, that is not quite enough, as I now discover: There are actually a few other packages that have also been updated. The changeset below may contain all of the appropriate updates (though I have not checked its completeness).

https://github.com/galaxyproject/tools-iuc/commit/c6433913f3863b1afd7a5202a9828ec558ab90f1

ADD REPLYlink written 2.3 years ago by jashapiro10
3

Fortunately, the IUC expected this, and preemptively hosted all dependent libraries elsewhere. I've updated the xml to download and install them from that host.

ADD REPLYlink written 2.3 years ago by Dave B.380
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 78 users visited in the last hour